Bug: Hiding rule doesn't work in Thunderbird 2

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey
Post Reply
Ares2
Posts: 1275
Joined: Fri Feb 15, 2008 12:47 pm

Bug: Hiding rule doesn't work in Thunderbird 2

Post by Ares2 »

I use ABP instead of userChrome.css/Stylish to hide some chrome elements in Thunderbird 2.0.0.18.

After the update to 1.0, one of my rules (to hide the menu) doesn't work any more:

Code: Select all

messenger###menubar-items
It's really strange because I just tested it with 0.7.5.5 again and it works.

userChrome.css also works with

Code: Select all

@namespace url(http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul);

#menubar-items { display: none !important; }
And this doesn't seem to affect all hiding rules because the other chrome rules I have still work. For example

Code: Select all

messenger###mail-bar2
still hides the second bar in the main window.

Can somebody reproduce this?
Last edited by Ares2 on Mon Dec 15, 2008 4:15 pm, edited 1 time in total.
Wladimir Palant
ABP Developer
Posts: 8395
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany
Contact:

Post by Wladimir Palant »

Yes, I see this as well. There is an element hiding hit but Adblock Plus lets the element display nevertheless for some reason.
Wladimir Palant
ABP Developer
Posts: 8395
Joined: Fri Jun 09, 2006 6:59 pm
Location: Cologne, Germany
Contact:

Post by Wladimir Palant »

Ares2
Posts: 1275
Joined: Fri Feb 15, 2008 12:47 pm

Post by Ares2 »

Works, thx.

Changed subject: "Bug: "
Post Reply