Only secure content is displayed...

Everything about using Adblock Plus on Internet Explorer
123

Only secure content is displayed...

Post by 123 »

I get this warning everytime I visit a site that uses https... when I disable ABP and restart IE the warning doesn't show.
User avatar
Spiff
Posts: 15
Joined: Fri Nov 22, 2013 10:05 pm
Location: Netherlands

Re: Only secure content is displayed...

Post by Spiff »

My apologies for the late reply, I only just registered to the forum.
On topic:

I get the same Internet Explorer "Only secure content is displayed" notification messages, since I installed Adblock Plus 1.1 for Internet Explorer (with EasyList + EasyList Dutch).
Not for every https site, but on sites that use some mixed http/https content, I guess.
(see: http://support.microsoft.com/kb/2625928/en)

Two examples of sites that generate that "Only secure content is displayed" message in Internet Explorer with Adblock Plus 1.1 for Internet Explorer enabled:
https://startpage.com/
https://www.security.nl/

The strange thing is, before installing Adblock Plus 1.1 for Internet Explorer (with EasyList + EasyList Dutch), I did not get that "Only secure content is displayed" message on those sites.
With using the EasyList Standard and Dutch EasyList adblocking list TPLs ('Tracking Protection Lists') (and also the EasyPrivacy Tracking Protection List) on most pages I did not get those Internet Explorer "Only secure content is displayed" messages. (for TPLs, see: http://www.iegallery.com/en-US/trackingprotectionlists and http://www.iegallery.com/nl-NL/trackingprotectionlists)
So, I wonder what is it that Adblock Plus 1.1 for Internet Explorer does that causes those "Only secure content is displayed" messages on certain pages and that the EasyList Standard and Dutch EasyList adblocking TPLs do not do?
Does anyone know?
Is it a bug, or is it a feature?
Will it be corrected in a next build?
Is there a way to modify the mentioned behavior other than to change the setting in Internet Options to enable the display of mixed content? (Which is not recommended as that is an 'unsafe' setting, "this setting may make your computer vulnerable to viral, fraudulent or malicious attacks".)

System details:
Windows Vista Ultimate 32 bit (version 6.0.6002 SP2 Build 6002)
Internet Explorer 9 32 bit (version 9.0.8112.16421)
Adblock Plus for Internet Explorer (version 1.1.0.0)

Best regards
User avatar
Spiff
Posts: 15
Joined: Fri Nov 22, 2013 10:05 pm
Location: Netherlands

Re: Only secure content is displayed...

Post by Spiff »

Does no one else experience that same issue that user 123 and I (Spiff) reported?
Anyone?
And can anyone say if the reported issue is a bug, or might be a 'feature'?
If it's a bug, I will report in the Bug reports forum, but first I would like to know if it might be 'normal' behavior for Adblock Plus 1.1 for Internet Explorer.

Thanks.
GJL
Posts: 89
Joined: Fri Aug 30, 2013 12:52 pm

Re: Only secure content is displayed...

Post by GJL »

Spiff wrote:Does no one else experience that same issue that user 123 and I (Spiff) reported?
Anyone?
And can anyone say if the reported issue is a bug, or might be a 'feature'?
If it's a bug, I will report in the Bug reports forum, but first I would like to know if it might be 'normal' behavior for Adblock Plus 1.1 for Internet Explorer.

Thanks.
Yeah, same mildly annoying "Only secure content is displayed" message here with ABP 1.1 + Easylist (not Dutch). It has become a regular feature since I removed an add-on that was stopping ABP from working properly. Before removing the clashing add-on I very rarely saw the "Only secure content is displayed" message but ABP did not block ads until "Disable everywhere" was toggled off & back on.

It may well be just another "feature" of IE that we will have to live with until someone at Microsoft finally fires whoever it happens to be that thinks we all love seeing a continual stream of pop-up messages..
User avatar
Spiff
Posts: 15
Joined: Fri Nov 22, 2013 10:05 pm
Location: Netherlands

Re: Only secure content is displayed...

Post by Spiff »

Hi, GJL,
Thank you for confirming the issue.

And yes, I know those "Only secure content is displayed" prompts for mixed http/https content that's an Internet Explorer feature (http://support.microsoft.com/kb/2625928/en).
But the odd thing is, as I said November 24, before installing and enabling Adblock Plus 1.1 for Internet Explorer (or after disabling it), and with or without using the EasyList Standard and Dutch EasyList adblocking list TPLs ('Tracking Protection Lists') (and also the EasyPrivacy Tracking Protection List), on most pages I did not get those Internet Explorer "Only secure content is displayed" messages. (for TPLs, see: http://www.iegallery.com/en-US/trackingprotectionlists and http://www.iegallery.com/nl-NL/trackingprotectionlists)
So, I wonder what is it that Adblock Plus 1.1 for Internet Explorer does that causes those "Only secure content is displayed" messages on certain pages and that the EasyList Standard and Dutch EasyList adblocking TPLs do not do?

There was not a conflicting add-on (plug-in nor extension) that I had to disable or remove to get Adblock Plus 1.1 for Internet Explorer working, so that cannot be a reason for getting those "Only secure content is displayed" prompts for mixed http/https content now that Adblock Plus 1.1 for Internet Explorer is installed and enabled, I suppose.
(Add-ons in IE: Adobe Flash Player, Adblock Plus 1.1 for Internet Explorer, PDF-XChange Viewer IE-plugin, Microsoft Silverlight, VTExplorer, WOT, and a bunch of default Microsoft add-ons for IE.)

So, I am still wondering, what is it that Adblock Plus 1.1 for Internet Explorer does that causes those "Only secure content is displayed" messages on certain pages and that the EasyList Standard and Dutch EasyList adblocking TPLs do not do?
Does anyone know?
Is it an Adblock Plus for IE feature?
Is it an Adblock Plus for IE bug?
Will it be corrected in a next build?

Best regards
User avatar
Spiff
Posts: 15
Joined: Fri Nov 22, 2013 10:05 pm
Location: Netherlands

Re: Only secure content is displayed...

Post by Spiff »

Er ... I know that the Adblock Plus for Internet Explorer forum is not moderated like the Bug reports forum.
But nevertheless, I would think someone of the Adblock Plus for IE team would be able to notice a case like this and indicate whether the reported issue should be classified as an Adblock Plus for IE bug and needs to be referred to the Bug reports forum, or whether the reported issue should be classified as an Adblock Plus for IE feature. :?
Anyone?
Thanks.
User avatar
Spiff
Posts: 15
Joined: Fri Nov 22, 2013 10:05 pm
Location: Netherlands

Re: Only secure content is displayed...

Post by Spiff »

As there was no reply from the Adblock Plus for IE team,
I have now reported in the Bug reports forum,
topic ABP for IE, "Only secure content is displayed" notifications

Best regards
Hollis

Re: Only secure content is displayed...

Post by Hollis »

I have this same issue using IE 11. It is not IE doing it because I have never seen that message before and I saw it right after I installed adblock plus. Also the formatting is all messed up on yahoo pages beyond the homepage. Just disabling adblock plus doesn't fix the formatting problem. I have to uninstall it altogether in order to fix it. It's definitely adblock plus doing it.
User avatar
mapx
Posts: 21942
Joined: Thu Jan 06, 2011 2:01 pm

Re: Only secure content is displayed...

Post by mapx »

User avatar
Spiff
Posts: 15
Joined: Fri Nov 22, 2013 10:05 pm
Location: Netherlands

Re: Only secure content is displayed...

Post by Spiff »

mapx wrote: how to disable the message:
http://forum.thewindowsclub.com/microso ... lorer.html
That is a way to disable "Only secure content is displayed" messages in Internet Explorer,
by enabling "Display mixed content" in Internet Explorer,
but that is not recommended.

By enabling "Display mixed content" in Internet Explorer, you lower the security settings.
See:
https://support.microsoft.com/kb/2625928/en:
"Internet Explorer blocks non-secure content to keep your information safe and is set to Prompt by default. When this setting is set to Enable, Internet Explorer does not prompt you with the "Only secure content is displayed" message even if the webpage is using non-secure elements."
So:
If you do not want to lower your Internet Explorer security settings, do not enable "Display mixed content".

The same reply was given February 13, 2014, in the ABP for IE, "Only secure content is displayed" notifications thread.

N.B.
That mentioned ABP for IE, "Only secure content is displayed" notifications thread was started December 1, 2013, posted at the Bug reports forum, but for some reason there was never a response by the Adblock Plus team and the topic was moved from the Bug reports forum to the Adblock Plus for Internet Explorer forum.

I am still waiting for a response by the Adblock Plus team.
Not with a suggestion to enable "Display mixed content" in Internet Explorer, and thus lowering security settings,
but by analyzing the issue that was originally posted as a bug report and planning to fix that issue with the next Adblock Plus for Internet Explorer build.
Thanks.
User avatar
mapx
Posts: 21942
Joined: Thu Jan 06, 2011 2:01 pm

Re: Only secure content is displayed...

Post by mapx »

you could open a bug on the issue tracker:
https://issues.adblockplus.org
User avatar
Spiff
Posts: 15
Joined: Fri Nov 22, 2013 10:05 pm
Location: Netherlands

Re: Only secure content is displayed...

Post by Spiff »

mapx wrote: you could open a bug on the issue tracker:
https://issues.adblockplus.org
OK, if that is what it takes.
But I do not understand why the issue was never picked up when posted to the Bug reports forum, and why the topic was moved from the Bug reports forum to the Adblock Plus for Internet Explorer forum.

Secondly,
How and what should I post on the issue tracker?
Can I post a link to my report that was originally posted at the Bug reports forum?
And what should I choose for Component, Status, Type, and Priority?

Thanks.
User avatar
mapx
Posts: 21942
Joined: Thu Jan 06, 2011 2:01 pm

Re: Only secure content is displayed...

Post by mapx »

file only "component" ==> abp for ie

describe the issue
you can also add the link to the original issue
User avatar
Spiff
Posts: 15
Joined: Fri Nov 22, 2013 10:05 pm
Location: Netherlands

Re: Only secure content is displayed...

Post by Spiff »

mapx wrote: file only "component" ==> abp for ie

describe the issue
you can also add the link to the original issue
Ok, thanks.
I'll get to it, this morning, or later today.
User avatar
Spiff
Posts: 15
Joined: Fri Nov 22, 2013 10:05 pm
Location: Netherlands

Re: Only secure content is displayed...

Post by Spiff »

Spiff wrote: I'll get to it, this morning, or later today.
Now posted on the issue tracker, see:
https://issues.adblockplus.org/ticket/374
Post Reply