Why AdBlock Plus does not respect some element (cosmetic) filters?

Everything about using Adblock Plus on Microsoft Edge
Post Reply
borisf98
Posts: 11
Joined: Sat Dec 24, 2022 6:11 am

Why AdBlock Plus does not respect some element (cosmetic) filters?

Post by borisf98 »

For example, elements like this are not enforced.


Some of those do not work

^=
*=
$=

Some are not enforces. Why?
Last edited by borisf98 on Wed Jan 18, 2023 4:03 am, edited 1 time in total.
borisf98
Posts: 11
Joined: Sat Dec 24, 2022 6:11 am

Re: Why AdBlock Plus does not respect some element (cosmetic) filters?

Post by borisf98 »

Actually some are respected and some not.
[href mostly works.

Example on something that does not work
On this page
https://olympics.com/en/athletes/eliud-kipchoge

I am trying to select element
olympics.com##.Adstyles__Wrapper-sc-1ad7161-0.ipScpO

I am trying to create filter
olympics.com##[class*="Adstyles"]

Does not work.
User avatar
greiner
ABP Developer
Posts: 865
Joined: Mon Sep 03, 2012 5:29 pm
Location: Cologne, Germany

Re: Why AdBlock Plus does not respect some element (cosmetic) filters?

Post by greiner »

The filter you mentioned (i.e. `olympics.com##[class*="Adstyles"]`) seems to work as expected, so I'm not able to reproduce that problem, unfortunately. So the element is not visible to me and the developer tools show that the correct styles were applied to that element to get hidden.

One thing to note, in case that's what you're seeing: If you have more than one element hiding / cosmetic filter that's active on the page, there's a bug in the current version of Adblock Plus, which causes only one of them to be shown in the Adblock Plus developer tools panel (see ui#1309). So there it may look like the filter wasn't applied, even though it was. We're going to fix that bug as part of the upcoming Adblock Plus 3.16 update.

Otherwise, maybe you could provide some more information about your browser version, Adblock Plus version and other filters and filter lists you have installed, to help me try to reproduce what you're experiencing. If you want, you can use the built-in issue reporter for that, via the "Report an issue on this page" button in the icon popup menu.
borisf98
Posts: 11
Joined: Sat Dec 24, 2022 6:11 am

Re: Why AdBlock Plus does not respect some element (cosmetic) filters?

Post by borisf98 »

I made mistake. Move this thread to Edge section.

Latest Edge browser. Windows 10. AdblockPlus 3.15.2.

I tried other samples for partial elements.

[href

works

while
[id
[class

does not.
User avatar
greiner
ABP Developer
Posts: 865
Joined: Mon Sep 03, 2012 5:29 pm
Location: Cologne, Germany

Re: Why AdBlock Plus does not respect some element (cosmetic) filters?

Post by greiner »

Thanks for the additional information. I've moved the topic to the Edge subforum, but I'm still unable to reproduce the problem using Edge 105.
borisf98
Posts: 11
Joined: Sat Dec 24, 2022 6:11 am

Re: Why AdBlock Plus does not respect some element (cosmetic) filters?

Post by borisf98 »

It is on my end. I disabled my personal filters and problem is solved. Tried with other browsers and no problem.
Last edited by borisf98 on Tue Jan 24, 2023 2:23 am, edited 2 times in total.
borisf98
Posts: 11
Joined: Sat Dec 24, 2022 6:11 am

Re: Why AdBlock Plus does not respect some element (cosmetic) filters?

Post by borisf98 »

Even more interesting. Disabled personal filters, reloaded slightly updated ones from Google Drive and enabled filters again: now no problem. Something is/was going on with uploading filters from Google Drive.
Post Reply