New issues with Youtube

Everything about using Adblock Plus on Mozilla Firefox, Thunderbird and SeaMonkey
Youtub&AdblockNoWork
Posts: 5
Joined: Mon Mar 07, 2016 11:01 am

Re: New issues with Youtube

Post by Youtub&AdblockNoWork »

I have this problem also and created a forum account specially because of that problem.


Problem : On some Youtube videos, when the page loads, the videos stays black with nothing happening and, after 15/30 seconds, the video starts to play.
Configuration : Windows 10 x64, Firefox 44.0.2 x32, Adblock Plus 2.7.2

Possible cause of the problem : I tried several things (including what you said mapx), and I think I found the source of the problem. The problem seems to be related to your Google/Gmail/Youtube account. Each time I log in my Youtube account I have the problem; but as soon as I log out, the problem disappears.
I would like other people, that have the problem, to test this out : simply log out of your Google/Gmail/Youtube account and try on different videos (PewDiePie videos are good to test, because he has "pre-video ads" on almost all his videos).


Please keep us informed.
User avatar
mapx
Posts: 21942
Joined: Thu Jan 06, 2011 2:01 pm

Re: New issues with Youtube

Post by mapx »

I tested for example
https://www.youtube.com/watch?v=2gADntFQQ9U

it started quickly, no issue here (logged in my google / YT account).

Do you have a g+ account ?
Youtub&AdblockNoWork
Posts: 5
Joined: Mon Mar 07, 2016 11:01 am

Re: New issues with Youtube

Post by Youtub&AdblockNoWork »

Yes I have a G+ account but I don't use it.

The problem could be on several Youtube accounts, not all of them.
Or Youtube, after some time, associates/flags a Youtube account to a Adblock users, and then the problem appears.


If I don't use my Youtube account, Adblock works well and I don't have any problems.
If I use my Youtube account, I have the problem with Adblock. If I use my Youtube account on another computer or internet connection with Adblock, the problem will be present.
User avatar
mapx
Posts: 21942
Joined: Thu Jan 06, 2011 2:01 pm

Re: New issues with Youtube

Post by mapx »

Did you test the same account / videos on chrome ?
Youtub&AdblockNoWork
Posts: 5
Joined: Mon Mar 07, 2016 11:01 am

Re: New issues with Youtube

Post by Youtub&AdblockNoWork »

I was going to test out Chrome + Adblock + my Youtube account, but the problem disappeared on my usual browser :?
If or when it starts again, I'll test out Chrome + Adblock + my Youtube account.
Terkoz
Posts: 3
Joined: Thu Mar 10, 2016 2:38 am

Re: New issues with Youtube

Post by Terkoz »

Another here having the same issues. ABP no longer works properly for me. The ads do not show but either show a blank screen for the duration of them or else the error message for the same period. Logging out from youtube is not a worthwhile solution as then I would not have access to my subscriptions.

Hopefully this can be addressed soon. I appreciate it may not be an easy fault to find but at the moment there is not much point me using the extension.
User avatar
mapx
Posts: 21942
Joined: Thu Jan 06, 2011 2:01 pm

Re: New issues with Youtube

Post by mapx »

if it's not only about YT, you should refresh firefox, reinstall ABP.
Mckay
Posts: 1
Joined: Fri Mar 11, 2016 8:13 pm

Re: New issues with Youtube

Post by Mckay »

Youtub&AdblockNoWork wrote:I have this problem also and created a forum account specially because of that problem.


Problem : On some Youtube videos, when the page loads, the videos stays black with nothing happening and, after 15/30 seconds, the video starts to play.
Configuration : Windows 10 x64, Firefox 44.0.2 x32, Adblock Plus 2.7.2

Possible cause of the problem : I tried several things (including what you said mapx), and I think I found the source of the problem. The problem seems to be related to your Google/Gmail/Youtube account. Each time I log in my Youtube account I have the problem; but as soon as I log out, the problem disappears.
I would like other people, that have the problem, to test this out : simply log out of your Google/Gmail/Youtube account and try on different videos (PewDiePie videos are good to test, because he has "pre-video ads" on almost all his videos).


Please keep us informed.
It seems like some accounts are getting flagged, which causes an invisible "ad" to play before your video, acting as a nuiscance. Logging out or creating an account solves this problem. I think they intentionally added a playback delay for these flagged accounts.
Youtub&AdblockNoWork
Posts: 5
Joined: Mon Mar 07, 2016 11:01 am

Re: New issues with Youtube

Post by Youtub&AdblockNoWork »

mapx wrote:Did you test the same account / videos on chrome ?
The problem appeared again.

I tested with chrome 49.0.2623.87, Adblock Plus 1.10.1 and my "flagged" Youtube account.
The results are weird, when I went to play the videos I get the message "An error occured. Please try gain shortly" and if I don't touch anything, 15 to 30 seconds after, the videos starts to play :shock:

Image

Mckay wrote:It seems like some accounts are getting flagged, which causes an invisible "ad" to play before your video, acting as a nuiscance. Logging out or creating an account solves this problem. I think they intentionally added a playback delay for these flagged accounts.
At this point, it really seems Google is flagging Adblock users :cry:
Zeak
Posts: 13
Joined: Wed Mar 09, 2016 9:43 pm

Re: New issues with Youtube

Post by Zeak »

As per HackerNews https://news.ycombinator.com/item?id=11270618

The solution seems to be to turn off "Ads based on your interests" here: https://www.google.com/settings/u/0/ads ... ated?hl=en
Placid
Posts: 3
Joined: Tue Mar 15, 2016 6:48 am

Re: New issues with Youtube

Post by Placid »

Also registered to chime in on this.

I have the exact same issues, there is a pause of varying length (10 - 30 seconds, guess thats the actual ad length or something)..then the video starts. Sometimes, the video will start with only sound, and no picture. Sometimes Youtube will give an error "something wrong has happened, try again later" (or similar).

Logging out of my account works brilliantly, in that adblock works perfectly. Videos starts immediately, not a second of pause, no problems at all. Except for the subscriptions, etc of course :)
Zeak wrote:As per HackerNews https://news.ycombinator.com/item?id=11270618

The solution seems to be to turn off "Ads based on your interests" here: https://www.google.com/settings/u/0/ads ... ated?hl=en
Does not work. Mine was off, i tried setting it on just for the fun of it (it didn't make a difference). So i turned it back off again after a while.

Edit : After a few hours it seems to be working normally (IE, as it should, with no pauses or black screens). When going over the Google settings mentioned in the quote, i disabled everything (most already was disabled, only "Youtube Video Searches" or similar was active). Maybe it was just a delay for the settings to be implemented throughout Google's systems, i dont know... i'll come back and complain if it reappears, but for now, 3 weeks of this crap seems blissfully over :D



Terkoz
Posts: 3
Joined: Thu Mar 10, 2016 2:38 am

Re: New issues with Youtube

Post by Terkoz »

Turning off the targeted ads fixed the problem for me. Thanks guys.
munkitkat
Posts: 6
Joined: Mon Mar 07, 2016 12:08 pm

Re: New issues with Youtube

Post by munkitkat »

Just wondering if the developer is made aware of this issue? :shock:
User avatar
mapx
Posts: 21942
Joined: Thu Jan 06, 2011 2:01 pm

Re: New issues with Youtube

Post by mapx »

munkitkat wrote:Just wondering if the developer is made aware of this issue? :shock:
try
https://www.google.com/settings/u/0/ads ... ated?hl=en
Placid
Posts: 3
Joined: Tue Mar 15, 2016 6:48 am

Re: New issues with Youtube

Post by Placid »

After a couple of blissful days of everything working perfectly, the dreaded "pausing" has returned (every possible setting in Google is set to off, when logging out, adblock works exactly as it should, etc).

If i am the only one experiencing it, i guess the problem could be on my end (though i am at a complete loss as to why).
Locked